Matik down

Incident Report for Matik Inc

Resolved

This incident has been resolved
Posted Nov 25, 2025 - 22:25 UTC

Investigating

We are investigating a potential Matik outage.
Posted Nov 25, 2025 - 22:02 UTC
This incident affected: Matik API and Matik App.