This incident should be resolved. The fix will apply to all generations going forward. (If a previous PowerPoint was affected by the issue, you may need to generate it again to get a clean working file.)
Posted Jun 04, 2025 - 19:03 UTC
Monitoring
We've released a potential fix and are monitoring the results.
Posted Jun 04, 2025 - 16:56 UTC
Investigating
We are investigating an issue that is impacting some PowerPoint generations. In these cases, the generated PowerPoint file displays a "Sorry, we can't open this presentation" error message.
We are working on a fix, but in the meantime, you should still be able to download the file, click 'Repair' when prompted, and use the presentation file.