Excel data sources issue

Incident Report for Matik Inc

Resolved

This has been resolved.
Posted Apr 30, 2025 - 23:23 UTC

Monitoring

A fix has been implemented which should resolve the issue. We're monitoring performance to be sure.
Posted Apr 30, 2025 - 23:08 UTC

Identified

We have identified an issue that may be impacting Excel and Excel 365 data sources. We are expecting to launch a fix later today.
Posted Apr 30, 2025 - 21:57 UTC
This incident affected: Matik App.